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Unable to see the NAS proxy in the Phoenix UI after installation.

Unable to see the NAS proxy in the Phoenix UI after installation.

Updated over 3 weeks ago

Problem Description

Unable to see the NAS proxy in the Phoenix UI after installation.

Traceback

Windows Server

  • For agent versions prior to 7.0.0:
    Logs can be found at:
    ​C:\ProgramData\Phoenix\main_service.log

  • For agent versions 7.0.0 and later:
    Logs are located at:
    ​C:\ProgramData\Druva\EnterpriseWorkloads\Controlservice\controlservice.log

Linux Distributions (CentOS, RHEL, SLES, Ubuntu)

  • For agent versions prior to 7.0.0:
    Logs are available at:
    ​/var/log/Phoenix/main_service.log

  • For agent versions 7.0.0 and later:
    Logs are located at:
    ​/var/logs/Druva/EnterpriseWorkloads/Controlservice/controlservice.log

  • The NAS plugin starts successfully and completes proxy creation:

  • Successfully created new proxy entry. Proxy Id [4037]

  • Successfully updated proxy config entries

  • However, the following error is observed during registration update:

  • REST call failed URL=/proxies/{proxyID:[0-9]+} method=PATCH

  • Access or registration issue

Cause

The NAS proxy is registered with a different Organization than the one selected in the Phoenix UI, especially in environments with multiple Organizations.

Resolution

If your account has multiple Organizations, ensure that:

  • The Activation Token used during proxy setup is generated from the same Organization where you want the NAS proxy to appear.

  • Re-generate the token from the correct Organization and re-register the proxy if needed.

Next Steps

  • Log in to Phoenix Console.

  • Navigate to: NAS > Proxies > Generate Activation Token

  • Select the correct Organization.

  • Use the token to register or re-register the NAS proxy.

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