Skip to main content
All CollectionsKnowledge BaseEnterprise WorkloadsTroubleshooting - Enterprise Workloads
App aware backup completes successfully with Credentials are not assigned to Guest VM error
App aware backup completes successfully with Credentials are not assigned to Guest VM error
Updated over 10 months ago

Problem description

App aware backup completes successfully with “Credentials are not assigned to Guest VM” error.

Cause

This issue occurs if app aware backup is triggered for a Virtual Machine which does not have credentials assigned to it from the credential store.

Traceback

Download the job logs with the steps provided in the Logs section and extract the logs and navigate to the Phoenix<YYYY/MM/DD>-<timestamp>.log file . Check if you have the below traceback in the logs.

[2020-01-16 17:37:08,629] [WARNING] Guest VM Credential not assigned 4295032861 VMware App Aware Processing: Guest VM Credential not assigned. Please assign credential for the specified VM. Application aware backup would have just VM backup and would complete with Successful with errors.

To verify the same from the Progress Logs on the Phoenix Management Console:

  1. Go to the Jobs page, and open the VMware tab.

  2. Click the Job ID that completed with errors.

  3. On the Job Details page, open the Progress Logs tab to view the logs.

    JobDetails2.png

Resolution

  1. Assign credentials to the Virtual Machine for app-aware backups to run successfully. See Manage credentials for VMware for details.

  2. Ensure that credentials are mapped to this VM from the credential store. For more information, see Application-aware backup is failing on virtual machines if the credentials of the VM provided to Phoenix belong to a non-admin user.

Verification

Once the changes are done, trigger the backup job again and it should complete successfully.

See also

Did this answer your question?