Skip to main content
All CollectionsKnowledge BaseEnterprise WorkloadsTroubleshooting - Enterprise Workloads
App aware backup completes successfully with VM Tools status: toolsNotRunning error
App aware backup completes successfully with VM Tools status: toolsNotRunning error
Updated over 10 months ago

Problem description

App aware backup completes successfully with “VM Tools status: toolsNotRunning” error.

Cause

This issue occurs if app aware backup is triggered for a Virtual Machine which has outdated VMware tools or VMware tools services are in Stopped or Disabled state.

Traceback

Download the job logs with the steps provided in the Logs section and extract the logs and navigate to the Phoenix<YYYY/MM/DD>-<timestamp>.log file . Check if you have the below traceback in the logs.

[2020-01-02 01:12:48,579] [WARNING] VM Tools is either not installed or not running for vm: Kislay_cc_SQL_phx. Application aware backup would have just VM backup and would complete with Successful with errors

To verify the same from the Progress Logs on the Phoenix Management Console:

  1. Go to the Jobs page, and open the VMware tab.

  2. Click the Job ID that completed with errors.

  3. On the Job Details page, open the Progress Logs tab to view the logs.

    PhoenixJobLogs.png

Resolution

  1. Ensure that Vmware tools service is running on the Guest OS and is not in Stopped or Disabled state.

  2. Ensure that VMware tools are up to date on Guest OS. If the tools are outdated, update them using steps provided in Installing and upgrading VMware Tools in vSphere (2004754).

Verification

Once the changes are done, trigger the backup job again and it should complete successfully.

See also

Did this answer your question?