This article applies to inSync Cloud.
Problem description
inSync fails to update the last connected date of the device on the inSync Management Console when it updates the the backup status. Hence, the last connected date displayed is much before the backup date.
Cause
The wpsapi.dll file located at C:\Program Files (x86)\Druva\inSync get corrupt on the the affected device. Hence, stale device location and last connected date are displayed on the console.
Resolution
Upgrade inSync Client to the latest version on the device.
If the latest inSync Client is already installed on the device, reinstall the client to refresh all the dll libraries.