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inSync Client backup fails stating the device is disabled despite the device being active
inSync Client backup fails stating the device is disabled despite the device being active
Updated over a week ago

Problem description

As a usual practice, IT Admins provide a device replacement to existing users OR new users by cloning the old device, which includes copying over the Druva inSync configuration files as well.

Post replacing the device, the inSync client shows as active on the new device, but fails to backup with an error in the backup logs: The device has been disabled.

Cause

When a device is first activated with inSync Client, the device’s serial number is read by the client and sent over to Druva inSync cloud, which is then maintained in cloud on the backend.

This is only done at the time of activating the inSync client and cannot be manually changed later.

When you clone the device, the new device will have a new serial number but the inSync client is already active due to the existing configuration files from the old device.

Serial numbers can also get changed when you modify or upgrade the device’s hardware.

Hence, the new serial number does not get sent over to Cloud and the device is thus treated as disabled by Druva Cloud due to mis-match of the serial numbers.

Traceback


📝 Note
[2023-06-02 1815:59,516] [ERROR] Error <class 'inSyncLib.inSyncError.SyncError'>:The device has been disabled. (#100000074). Traceback -Traceback (most recent call last):File "inSyncLib\inSyncSyncer.pyc", line 4528, in syncFile "inSyncLib\inSyncSyncer.pyc", line 5045, in dosyncFile "inSyncLib\inSyncRPCBase.pyc", line 765, in __call__File "inSyncLib\inSyncRPCBase.pyc", line 1420, in _safe_requestFile "inSyncLib\inSyncRPCBase.pyc", line 1426, in _issue_requestFile "inSyncLib\inSyncRPCBase.pyc", line 938, in _issue_requestFile "inSyncLib\inSyncRPCBase.pyc", line 980, in __wait_responseSyncError: The device has been disabled. (#100000074)[2023-06-02 18:15:59,601] [WARNING] Backup failed. Error: The device has been disabled. (#100000074)[2023-06-02 18:15:59,898] [WARNING] Your device has not backed up for '30' days. (#100000039)


Resolution

As the serial number can be updated only at the time of inSync client activation, in such a case reactivating the client is the only solution.

Following steps can be used to reactivate the inSync client without uninstalling it:

1. Launch services.msc -> stop the “Druva inSync Client Service”

2. Launch Task manager -> details -> kill any tasks related with “inSync”.

3. Go to C:\ProgramData

4. Rename the “Druva” folder to Druva.old

5. Back to services.msc -> restart the “Druva inSync Client Service”

6. Re-activate the inSync client for the user and then trigger the backup.

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