Problem description
VMWare Backup for all VMs fails with ‘Backup Window Expired’ error.
Scheduled backups as well as manual backups fail with the same error.
It will also log PHOENIX158 Error in the job logs
date command on the backup proxy, returns incorrect date/time
Cause
Incorrect date/time configured on the Backup Proxy OR Time not updated on the Backup Proxy due to NTP Server issues
Traceback
2023-05-22 11:31:33,178] [INFO] roboSyncer: Sending log to Phoenix server with message : 'Starting backup operation.'
[2023-05-22 11:31:36,014] [ERROR] Error during init_estimate for share Metadata. Error: In progress backup request crossed the scheduled window time: 'Mon May 22 06:00:00 2023', in respect to current time: 'Mon May 22 11:31:36 2023' (#10000009e) (Error Code : PHOENIX158) [2023-05-22 11:31:36,020] [ERROR] Error during backup [2023-05-22 11:31:36,020] [ERROR] Error <class 'inSyncLib.inSyncError.SyncError'>:In progress backup request crossed the scheduled window time: 'Mon May 22 06:00:00 2023', in respect to current time: 'Mon May 22 11:31:36 2023' (#10000009e) (Error Code : PHOENIX158). Traceback -Traceback (most recent call last): SyncError: In progress backup request crossed the scheduled window time: 'Mon May 22 06:00:00 2023', in respect to current time: 'Mon May 22 11:31:36 2023' (#10000009e) (Error Code : PHOENIX158)
[2023-05-22 11:31:36,020] [INFO] roboSyncer: Sending log to Phoenix server with message : 'Exception occurred. Backup process will be marked as failed.' [2023-05-22 11:31:37,547] [INFO] roboSyncer: Sending log to Phoenix server with message : 'Finishing backup operation with status: 'Failed'.'
Resolution
Standalone ESXi Host Backup Proxy:
Connect to the backup proxy
Login: root
Password: druvaphoenix (default credentials unless changed)
Type in ProxyConf to access the Proxy’s configuration settings
Select the option to ‘Change the timezone’
Note:Backup Proxy requires a reboot post changing the timezone setting.Type Yes for the confirmation
Select the appropriate Continent or Ocean
Then Select the Country
Confirm the information by making the appropriate selection
Proxy will be rebooted post confirmation
vCenter backup proxy:
📝 Note
The Proxy VM needs to be powered off in order to be able to make changes in vApp.
In vCenter, select the Proxy VM and click on Configure tab
Select vApp Options
Scroll down to n_n_Time_Zone and select the radio button
Scroll up and click on SET VALUE
Select the desired Time Zone and click OK
Power ON the Proxy VM and changes should take effect.
Verification
Run the date command on the Backup Proxy and verify if it’s updated
Run a manual backup of one of the VM and check the status.