Skip to main content

Common causes of Druva backup failures to a Linux TurboTier.

Common causes of Druva backup failures to a Linux TurboTier.

Problem Description:

Understanding the flow of Linux TurboTier backups

  • If the backup Job Log shows the below line, it means the backup is mapped to Linux TurboTier.
    ​Attempting to connect to cache...
    Communication from Server / Backup Proxy to Linux CloudCache is configured on port 443. u'cacheaddr': u'DRUVA-CC:443'

  • If unable to connect to Linux TurboTier, there is a re-attempt every 30 Seconds. (Total 10 attempts)

    ​Error Connecting to cache server. Error:[Errno -2] Name or service not known Retrying...[9]

  • Once the 10 attempts are exhausted and if:

    • Option - Backup to Cloud if unable to backup to Cache is selected in Phoenix TurboTier configuration then backups are uploaded on Cloud
      ​Setting cache state as retried after retry cycle
      'Could not connect to CloudCache. Backup operation falling back to Cloud.'

    • Option - Backup to Cloud if unable to backup to Cache is not selected in Phoenix TurboTier configuration then backups will fail.
      ​'Could not connect to CloudCache. Failing the cache-only backup operation.’

Resolution

To ensure the Phoenix Linux TurboTier server is functioning correctly and connected to the Druva Console, follow these steps:

  • Confirm that the Phoenix Linux TurboTier server is in a connected state on the Druva Console.

  • Use the following commands on the Linux TurboTier server to manage or check the service status:

    • Agent Version 4.x.x:
      ​/etc/init.d/PhoenixCacheServer start / stop / restart / status

    • Agent Version 6.x.x:
      ​service Druva-EnterpriseWorkloads start / stop / restart /status

  • Ensure the Phoenix Linux TurboTier is upgraded to the latest version.

  • Test connectivity from the Backup Server/Backup Proxy to the Phoenix TurboTier server using:

    • telnet <CloudCache-name> 443

  • Check for DNS issues by pinging the Phoenix TurboTier server using its IP, short name, and FQDN:

    • ping <CloudCache-fqdn/CloudCache-ip/CloudCache-shortname>

  • If there are connection issues, add the Phoenix Linux TurboTier server entries to the Hosts file of the Backup Server/Backup Proxy in the format:

    • IP FQDN Short_name

  • Verify that the time on the Phoenix Linux TurboTier server is correctly set according to the selected time zone.

  • Ensure the data volume (PhoenixCacheStore) path configured during setup is accessible on the Phoenix TurboTier server.

  • Confirm that port 443 is not being used by any other application on the Phoenix TurboTier server. Use the following commands to verify:

    • netstat -an

    • netstat -an | grep 443

  • Check the PhoenixCloudCache.log file for errors:

    • /var/log/PhoenixCloudCache/PhoenixCloudCache.log

Did this answer your question?