Problem description
The Teams data shows “Backed up successfully” but the data will not be backed up.
Cause
When you create a team in Microsoft Teams, it will create a site with the same name as the SharePoint site, each channel in the team will have a folder with the same name in the main library of SharePoint site, normally the site takes a little bit of time to be created.
You could verify directly on the site if it's working, so with an admin account go to below link:
https://admin.microsoft.com/#/homepage
Then in the left pane click in Admin Center > SharePoint Online > Sites > Active Site.
on the sites list verify if a new site related to your team appears, in the URL column you can click on it in order to access it.
Traceback
[2022-10-07 06:59:03,230] [ERROR] Failed to get channel name from files folder api for channel : 19:cDcBJ0NVeqoxvedXE1p0VMydswr94kaGHhF3OpPd2sQ1@thread.tacv2, fault Internal Error!! Response Code: 404 Text:{"error":{"code":"NotFound","message":"Folder location for this channel is not ready yet, please try again later.","innerError":{"message":"Folder location for this channel is not ready yet, please try again later."}} (#100000010)
Resolution
Resolution
Need to wait till a new site appears on the page.
If the Auto discover sites for backup option is enabled, inSync auto-discovers new site collections every 24 hours.
If you want inSync to discover any new site before the next auto-discovery process runs, follow this procedure:
On the inSync Management Console menu bar, click the
icon to access the global navigation panel.
Click SaaS Apps.
Click Microsoft 365. An overview page that provides a holistic view of all the configured Microsoft 365 app appears.
On the left-hand panel, click SharePoint.
Click the
icon beside Auto Configuration and select Discover Sites. inSync discovers the sites added to the SharePoint Online setup of your organisation after the last auto-discovery process.
Verification
Once a new site appears, the backup should work fine