Problem Description
Upon attempting to add an organization within the Druva application, the Salesforce authentication process fails, resulting in a redirection to RemoteAccessErrorPage.apexp?error=invalid\_client\&error\_description=app+must+be+installed+into+org\&display=popup.
Cause
Effective September 2025, Salesforce enforces restrictions on the usage of uninstalled connected applications. Consequently, organization authentication will fail if the requisite permission has not been granted.
Resolution
To rectify this issue, the "Approve Uninstalled Connected Apps" permission must be enabled for the user's profile or assigned via a Permission Set prior to reattempting authentication.
In Salesforce, you can:
Create or modify a Permission Set.
Navigate to System Permissions > Edit.
Select the checkbox for Approve Uninstalled Connected Apps.
Allocate this permission set to the appropriate users.
