This article applies to:
OS: Windows
Product edition: inSync Client
Problem description
inSync fails to restore MAPI backup with the following error:
Cause
inSync fails to restore PST files when Outlook is not configured on the device. This occurs when inSync profile is confiured to back up Outlook with efficiency.
Refer Prerequisites for Outlook - 2016/13/10/07 - Optimized for efficiency backup in Include emails for backup on Windows
Traceback
Below is the error mentioned in the inSyncClient.log. The client logs are located in the following location.
C:\ProgramData\Druva\inSync4\users\UserName\logs
{code} [2019-03-23 05:35:17,657] [INFO] Restore params got {'dest': u'C:\\PST restore', 'src': u'./Sat Mar 23 03:16:22 2019/ParseError: EOF expected (click for details)Callstack: at (Knowledge_Base/inSync/Troubleshooting/Unable_to_restore_MAPI_backup), /content/body/div[2]/div[2]/p[2]/span/span, line 1, column 9', 'sys_state': False, 'req_id': 11226201, 'orig_loc': False} [2019-03-23 05:35:21,763] [ERROR] Error <class 'inSyncLib.inSyncError.SyncError'>:Outlook is not configured. (#10000004e). Traceback -Traceback (most recent call last): {code}
Resolution
Install and configure Outlook on the concerned machine and then initiate a fresh restore.
Verification
Once the restore is completed, kindly verify whether the PST file is restored successfully under restore tab and also verify the same under client log (inSyncClient.log )
Location of log file - C:\ProgramData\Druva\inSync4\users\UserName\logs where it is printed restore has been completed successfully.