This article applies to:
OS: All supported operating systems
Product edition: inSync Client version 5.5
Problem description
The backup status on the inSync Client displays the following error:
Error: Failed to backup. Check log for details.
Cause
inSync starts to back up the EDRM Metadata attributes and the error usually points to the mtime of the file. There have also been instances where the mtime was correct, yet this error was displayed. When the mtime is negative, the Python API to format the time fails with an exception causing this backup failure.
Traceback
💡 Tip
The following log excerpts are only examples. Date, time, and environmental variables may vary depending on the environment.
inSync Client logs
[2018-10-26 10:11:53,763] [INFO] Synchronizing \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy182\Users\abc\ntuser.dat.LOG2 starting at 0 [2018-10-26 10:30:38,752] [ERROR] Error <type 'exceptions.ValueError'>:unconvertible time. Traceback -Traceback (most recent call last): File "inSyncLib\inSyncSyncer.pyc", line 4147, in dosync File "inSyncLib\inSyncSyncer.pyc", line 4408, in syncfolders File "inSyncLib\inSyncSyncer.pyc", line 1983, in sync File "inSyncLib\inSyncSyncer.pyc", line 2092, in __syncfile File "inSyncLib\inSyncSyncer.pyc", line 1188, in sync ValueError: unconvertible time
[2018-10-26 10:30:38,877] [WARNING] Backup failed. Error: unconvertible time
Log locations:
Windows: C:\inSync4
Windows: C:\ProgramData\Druva\inSync4\Users\<username>\Logs
Mac: /Users/<username>/Library/Application Support/inSync
Linux: /home/<username>/.inSync/logs
Resolution
Upgrade the inSync Client to the latest version to resolve this issue.
This is a known issue in inSync Client version 5.5 and lower. This issue has been resolved in new builds of the client.