This article applies to:
Product edition: inSync Cloud
Problem description
In the process of enabling or disabling Sing Sign-On (SSO) for inSync Administrator on the inSync Management Console, the following error is displayed:
Could not update single sign-on for administrators settings. Invalid certificate or private key.
The error is also displayed during the same procedure on the Druva Cloud Platform (DCP) Console.
Cause
The IdP certificate in inSync Management Console is not in the correct format.
Resolution
Remove any unwanted spaces and blank lines present within the IdP certificate.
Comparison:
💡 Tip
Copy the IdP certificate from SAML response captured in SAML Message Decoder Tool to know the correct format of the certificate in case of any discrepancy.