All Collections
Knowledge Base
Druva Cloud Platform
Troubleshooting - Druva Cloud Platform
SSO login error “The signed in user is not assigned to the role for the application”( Azure as an IDP)
SSO login error “The signed in user is not assigned to the role for the application”( Azure as an IDP)
Updated over a week ago

Problem description

SSO app is configured however the user is unable to login to the admin or webrestore page

Cause

If a user isn't assigned to the Druva SSO app configured on the Azure side.

Traceback

Resolution

  • In the Azure AD portal, select Enterprise applications. Then find and select the Druva SSO application you have configured.

    • In the left navigation menu, select Users and groups.

    • Select the Add user/groups button.

    • On the Add Assignment pane, select Users and groups.

    • Select the user or group you want to assign to the application. You can also start typing the name of the user or group in the search box. You can choose multiple users and groups, and your selections will appear under Selected items.

  • After assigning the concerned user account to the Druva SSO app the user would now be able to login to DCP console via SSO

OR

  • You can make sure the setting “Assignment required” is set to NO for the Druva SSO app configured on the Azure AD side

  • You can set this option to No if you don't want to assign users individually to the app.

Did this answer your question?