Problem description
Google Shared Drive backup fails with status as “Backup Failed”
Cause
A shared drive has a member list where all the users who have access to the shared drive are added.
Shared drives also use groups where users are assigned to a group and the group is added to the shared drive.
It has been seen that this issue mostly occurs when a shared drive only has groups mapped to it.
Now, if we select a user from the group assigned to a particular shared drive. Add the user directly to the shared drive. Hence the user will be a part of the group as well as the shared drive directly.
Traceback
As per the Activity Stream logs, the error would look like below:
[2022-05-03 06:29:01,894] [INFO] Starting Google Shared Drives Backup for Shared Drives Accounting (TW) Customer 15855 [2022-05-03 06:29:08,382] [ERROR] Authentication failed with error No ORGANIZER/FILE_ORGANIZER found for the authorization of Google Shared Drives 0AGJM0UHzuc_RUk9PVA [2022-05-03 06:29:08,383] [ERROR] Error while Google Shared Drives backup for Accounting (TW) [2022-05-03 06:29:10,248] [INFO] Updated stats for teamdrive 102546. Stats filesMissed 0, filesSynced 0, sessionid 94268, customerid 15855, cloudapp_backup_status 4294967318 [2022-05-03 06:29:11,774] [INFO] Updated Backup Stats: fscurrentu 0, fstotalu 0, filesTotal 0, filescurrent 0, rptotal 0 [2022-05-03 06:29:11,774] [INFO] TeamDrive: 102546 disconnected, session: 94268, start: Tue May 3 06:29:01 2022, end: Tue May 3 06:29:11 2022, dur: 9.88059711456, Synchronized files: None, Missed files None, dataDone None
Resolution
If we select a user from the group assigned to a particular shared drive. Add the user directly to the shared drive. Hence the user will be a part of the group as well as the shared drive directly.
Basically, we need to have at least one inSync user in the member list of the Shared drive on the Google side to get the required ekeys for backup.
Post this change the backup should work fine.
Verification
After making above changes, the backup should work fine.