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Authentication Request timed out error when activating inSync Client on Mac OS using SSO
Authentication Request timed out error when activating inSync Client on Mac OS using SSO
Updated over 10 months ago

Problem description

If you are Single Sign-On (SSO) to authenticate inSync Client on Mac OS, you get the following error:

Request timed out

Cause

The default setting of 127.0.0.1 localhost IP on the Mac OS device has been modified in the Hosts file.

Client Log

[2020-02-07 11:20:51,242] [INFO] Trying to connect to cloud.druva.com:443. [2020-02-07 11:20:51,302] [INFO] Connection successful with cloud.druva.com:443. [2020-02-07 11:20:51,800] [INFO] Get_saml_request open_idp_in_browser True ,native_sso : False [2020-02-07 11:20:51,806] [INFO] Set Proxy details for Electron. samlUrl: https://xxxx.okta.com/app/druva/exk12yglefbKfCMGm1d8/sso/saml?SAMLRequest=fZLLTsMwEEX3%2FYoq%2B9ZJSiC12kqlFQ%2FxitrCgg1ynTFYOHbwOKX8PYnNe4F3npl75%2FjKE2SVqum8cU96BS8NoOv127OvlEbqm9Yr7ajIDxIopl3mnQ16gOxMz878LoJ%2Bdno9cL996%2BavQM%3D&RelayState=browseractivate [2020-02-07 11:20:59,228] [INFO] Main window active: True. PID 17058 [2020-02-07 11:20:59,229] [INFO] Tray, Bringing main window to foreground [2020-02-07 11:20:59,229] [INFO] Trying to bring Browser Window to foreground, pid: 17058 [2020-02-07 11:20:59,236] [INFO] SAML Auth: handleURLEvent_withReplyEvent_ Error - HTTPConnectionPool(host='localhost', port=7010): Max retries exceeded with url: /api/activate/do_saml_auth (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x10f5ae910>: Failed to establish a new connection: [Errno 61] Connection refused',)) [2020-02-07 11:21:50,145] [INFO] Cancel SAML Auth called

Resolution

  1. Open the hosts file on the Mac OS device in an editor. Path:/etc/hosts/

  2. 127.0.0.1 should point to the localhost. If this is pointing to any other URL, add # to convert this into comment-only.

  3. Save this and exit.

  4. Retry the inSync Client activation on the Mac OS.

See also

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