Problem Statement
You are unable to register or activate the eDiscovery client (version 2.1.0 or higher) on a Windows 11 machine. The registration process fails with an "internal error," preventing you from downloading the user-based data.
Cause
The eDiscovery client requires the WMIC (Windows Management Instrumentation Command-line) feature to identify your device. In some versions of Windows 11, WMIC may not be enabled or installed by default. This absence causes the client's registration process to fail.
Example Logs: The logs show the following error, which indicates that the system could not locate the required WMIC executable:”The system cannot find the file specified”
Default Log location: C:\ProgramData\Druva\eDiscovery\logs\parent_process.log
Traceback (most recent call last):
File "DDClientProcess\flaskserver\flask_routes.py", line 94, in create_client_post
File "DDClientProcess\poll_worker\poll_utils.py", line 21, in ping_client
File "common_lib\common_utils.py", line 272, in get_device_unique_id
File "common_lib\common_utils.py", line 270, in get_id
File "subprocess.py", line 424, in check_output
File "subprocess.py", line 505, in run
File "subprocess.py", line 951, in __init__
File "subprocess.py", line 1420, in _execute_child
FileNotFoundError: [WinError 2] The system cannot find the file specified
2025-07-02 11:42:41,177 MainProcess Thread-100 flask_server.py handle_unexpected_error() at 49 ERROR Exception while processing request.
Traceback (most recent call last):
File "common_lib\common_utils.py", line 268, in get_id
File "subprocess.py", line 424, in check_output
File "subprocess.py", line 505, in run
File "subprocess.py", line 951, in __init__
File "subprocess.py", line 1420, in _execute_child
FileNotFoundError: [WinError 2] The system cannot find the file specified
Resolution
To fix this, you need to manually enable the WMIC feature on your Windows 11 machine.
Open Command Prompt as an administrator.
Run the following command:
DISM/Online/Add-Capability/CapabilityName:WMIC~~~~
3. Allow 20-30 minutes for the installation to complete.
4. Once the installation is finished, try to register the eDiscovery client again.
After WMIC is installed, the eDiscovery client should register successfully, and you'll be able to download and access your data.
If the issue persists or for additional questions, contact Druva Support.