Skip to main content
All CollectionsKnowledge BaseEnterprise WorkloadsTroubleshooting - Enterprise Workloads
VMware backup proxy not visible with the Unable to set vCenter credentials error
VMware backup proxy not visible with the Unable to set vCenter credentials error
Updated over 10 months ago

Problem description

This error can occur while setting up any VMware backup proxy. When you try to connect to the FQDN/IP of the vCenter or an ESXi to validate credentials configured while setting up the proxy, the following error is displayed:
โ€‹

[Errno -2] Name or service not known

Cause

This error can occur while setting up any VMware backup proxy. When you try to connect to the FQDN/IP of the vCenter or an ESXi to validate credentials configured while setting up the proxy, the following error is displayed:
โ€‹

[Errno -2] Name or service not known

Traceback

Log location:

/var/log/Phoenix/ vCenterCred.log
[2020-09-29 03:16:09,932] [INFO] ==== vSphereCredetial process started.====
[2020-09-29 03:16:09,932] [INFO] vCenterCredential: request received for set credentials
[2020-09-29 03:16:09,932] [INFO] vCenterCredential: parameters are is_vmc: False  host: test.druva.com, username:  administrator@vsphere.local 
[2020-09-29 03:16:09,933] [INFO] vSphereCredManager: path for credential file is : /etc/Phoenix/.vsphere_credentials
[2020-09-29 03:16:09,933] [INFO] vSphereCredManager: Opening connection to vSphereAdapter
[2020-09-29 03:16:09,989] [ERROR] Unable to set vCenter credentials due to  error (vim.fault.HostConnectFault) {
dynamicType = <unset>,
dynamicProperty = (vmodl.DynamicProperty) [],
msg = '[Errno -2] Name or service not known',
faultCause = <unset>,
faultMessage = (vmodl.LocalizableMessage) []

Resolution

  1. Validate the FQDN/IP setting of vCenter/Esxi while configuring the backup proxy.

  2. Ensure that the NFC port 902 is open.
    โ€‹ Telnet <vcenter/esxi> 902

To verify whether the 902 port is open

  1. Open the vSphere Web Client.

  2. Go to Host and Clusters, select Host, and go to Configure > Firewall.

  3. Check the firewall rule.

  4. Select the firewall rule and click Edit if a modification is required.
    โ€‹

    Firewall_setting_VM.PNG
Did this answer your question?