Skip to main content
All CollectionsKnowledge BaseEnterprise WorkloadsTroubleshooting - Enterprise Workloads
Phoenix Agent installation fails due to an error during the installation of assembly policy
Phoenix Agent installation fails due to an error during the installation of assembly policy
Updated over 9 months ago

This article applies to:

  • OS: Windows 2008

  • Product edition: Phoenix

Problem description

Phoenix agent installation on Windows OS fails with the below error message:

An error occurred during the installation of assembly policy.9.0.Microsoft.VC90.CRT.

Cause

Usually this Microsoft.VC90.CRT error occurs due to corruption in Windows installer or .Net framework.

Traceback

Log Name: Application
Source: MsiInstaller
Date: 11/1/2019 2:36:12 AM
Event ID: 11935
Task Category: None
Level: Error
Keywords: Classic
User: abc
Computer: XYZ
Description:
Product: Druva Phoenix Agent 4.8.6 -- Error 1935. An error occurred during the installation of assembly 'policy.9.0.Microsoft.VC90.CRT,version="9.0.21022.8",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="amd64",type="win32-policy"'. Please refer to Help and Support for more information. HRESULT: 0x80070BC9. assembly interface: IAssemblyCacheItem, function: Commit, component: {F24CABFE-ED58-3012-A491-F671A890E4 >

Resolution

Resolve this issue using any of the following methods:

Method-1

Refer the below link to download and install the latest version of Microsoft Visual C++ 2008 Redistributable and verify.

Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package MFC Security Update
https://www.microsoft.com/en-gb/download/details.aspx?id=26368

Method-2

Check if the Windows installer service is running on the computer and is set to manual and service is started:

  1. Click Start menu in the search box type services.msc and then press Enter.

  2. In the Services (Local) list, right-click Windows Installer, and then click Properties.

  3. If the Startup type drop-down list is set to a value of Disable, select the Manual from the list, and then click OK.

  4. Click the File menu, and then click Exit.

Method-3

If the above steps fail then reinstall .Net framework on the computer and check.

To turn Windows features on or off, follow these steps:

  1. Click Start and go to Control Panel > Programs > Turn Windows features on or off.

  2. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

  3. To turn a Windows feature off, uncheck box next to Microsoft .NET Framework 3.5.1.

  4. Click OK and restart the computer.

  5. After the restart, open Turn Windows features on or off again and select the check box next to Microsoft .NET Framework 3.5.1 to turn a Windows feature on.

  6. Again click OK and restart the computer.

See also

Did this answer your question?