Skip to main content
All CollectionsKnowledge BaseEnterprise WorkloadsTroubleshooting - Enterprise Workloads
NAS backup fails with Authorization Error for Dell Isilon NAS Device
NAS backup fails with Authorization Error for Dell Isilon NAS Device
Updated over 3 weeks ago

Problem description

  • NAS backup fails with Authorization Error for Dell Isilon NAS Device as the NAS proxy will call Isilon metadata API on the directories/files to identify which files are stub files.

  • We do not backup the stub files by default because there are symlink or soft link files which don't contain the data, it only refers to the data.

  • Stub files will not get backup and agent will skip these files for default behaviour.

  • By default the value of parameter STUB_BACKUP_ENABLED is false in Phoenix.cfg of NAS proxy.

Cause

Dell Isilon NAS Device doesn't have the CloudPool License

Verification

Verify value of parameter(STUB_BACKUP_ENABLED) in Phoenix.cfg / Config.yaml of NAS proxy

Resolution

  • Users can make the changes in Configuration(Phoenix.cfg / Config.yaml ) file of NAS Proxy to skip the STUB file stat command to avoid identifying the STUB files.

  • Follow below steps:

    • Login to NAS proxy

    • Edit Configuration file
      Agent version 6.x : Phoenix.cfg

      Agent version 7.x : NAS specific Config.yaml file

    • Change the value of below parameter to True from False

      • Agent Version 6.x.x:

        STUB_BACKUP_ENABLED = True.

      • Agent Version 7.x.x:
        STUB_BACKUP_ENABLED : true

    • Restart Agent Client Service.

      ​Agent Version 6.x.x: service Phoenix restart

      Agent Version 7.x.x: service Druva-EnterpriseWorkloads restart

Did this answer your question?