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How to resolve "Unable to connect to Microsoft 365. Check connector status" Cloud App status alert

Updated this week

This article applies to:

  • Product edition: inSync Cloud

Problem description

Unable to connect to Microsoft 365 Advanced app. Check configuration status. All the Microsoft 365 workload backups fails with error EAUTH.

Cause

A few of the reasons why this occurs are as follows:

  • One of the Druva Microsoft 365 apps is deleted.

  • Global admin is disabled or deleted.

  • Microsoft 365 tenant policy-level changes.

  • Conditional access policy is applied.

  • MFA is enabled on the Microsoft 365 environment.

User Debug Logs

[2024-08-07 11:46:06,111] [ERROR] Error in generating access token for user=shoebs3@druvadataspl.in, Error='unicode' object has no attribute 'get', client in use=2b74c147

[2024-08-07 11:46:06,112] [ERROR] Cloud App Office 365 authentication failure. Disconnecting app, creating CloudAppStatus alert.

[2024-08-07 11:46:06,113] [ERROR] Error <class 'inSyncLib.inSyncError.SyncError'>:The user key is either invalid or the username no longer exists. (#100000016). Traceback -Traceback (most recent call last):

File "/opt/Druva/inSync/active/src/drcloud/Srv/Worker.py", line 3251, in check_cloudapp_status

__check_cloudapp_status(r, authinfo, backupinfo, ddict['userid'])

File "/opt/Druva/inSync/active/src/drcloud/Srv/Worker.py", line 3291, in __check_cloudapp_status

sessionid = AgentAPI.authenticate(backupinfo['apptype'], authinfo, graph_endpoint=True)

File "/opt/Druva/inSync/active/src/drcloud/Lib/CloudApps.py", line 112, in authenticate

raise SyncError(inSyncError.EAUTH)

SyncError: The user key is either invalid or the username no longer exists. (#100000016)

Resolution

To Re-Install inSync with Microsoft 365:

  1. On the inSync Management Console menu bar, click the icon to access the global navigation panel.

  2. Click SaaS Apps > Microsoft 365.

  3. On the Overview page, click on the “Manage Apps” button on the top right corner of the screen.

4. On the Manage Apps page, click on the 3 dots besides the app type that you want to reinstall.

5. On the confirmation pop-up, click Re-Install to proceed with reconfiguration.

6. On the Microsoft 365 login page, enter the Microsoft 365 global administrator's user name and password, and then click Sign in. Click Accept to grant the inSync app the required permissions to access Microsoft 365 data.


Note - The permissions displayed are a combined list for all Microsoft 365 apps. inSync gets connected to the Microsoft 365 data of all users in your organization.

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