Problem description
Gmail /Google Drive backup fails showing the error ‘ETHROTTLE” on the inSync management console.
Cause
'User Rate-limits' are exceeded.
'User Rate-limits' are defined by Google, which means that it allows a certain number of requests per/user within certain time limits. We handle such scenarios by doing 6 retries with exponential backoff as mentioned in the below google document.
Snippet from the above article:
As the Google Drive API is a shared service, we apply quotas and limitations to make sure it's used fairly by all users and to protect the overall performance of the Google Workspace system.
If you exceed a quota, you'll receive a “403: User rate limit exceeded” HTTP status code response. Additional rate limit checks on the Drive backend might also generate a “429: Too many requests response”.
If this happens, you should use an exponential backoff algorithm and try again later. Provided you stay within the per-minute quotas below, there's no limit to the number of requests you can make per day.
The following table details the query limits:
Traceback
We can check for the traceback from user logs which are available to download from inSync Admin console.
"status": "PERMISSION_DENIED", "details": [ { "@type": "type.googleapis.com/google.rpc.ErrorInfo", "reason": "RATE_LIMIT_EXCEEDED", "domain": "googleapis.com", "metadata": { "quota_location": "global", "service": "gmail.googleapis.com", "consumer": "projects/xxxxxxxxxxx", "quota_limit": "defaultPerMinutePerProject", "quota_limit_value": "2400000", "quota_metric": "gmail.googleapis.com/default" } }, { "@type": "type.googleapis.com/google.rpc.Help", "links": [ { "description": "Request a higher quota limit.", "url": "https://cloud.google.com/docs/quota#requesting_higher_quota" } ]
Resolution
Increase the maximum quota amount for google tenant.