Skip to main content

Backups to CloudCache are failing with the error: “Could not connect to CloudCache.”

Backups to CloudCache are failing with the error: “Could not connect to CloudCache.”

Updated today

Problem Description:

Backups to CloudCache are failing with the error: “Could not connect to CloudCache.”

Traceback

The following error is observed in logs:

Logs:

  • Linux (CloudCache R1): /var/log/PhoenixCloudCache/

  • Linux (CloudCache R3): /var/log/Druva/EnterpriseWorkloads/cloudcache/

[2024-10-09 10:02:35,196] [INFO] ....client disconnected

[2024-10-09 10:02:35,197] [INFO] client not authenticated, peer None

[2024-10-09 10:02:35,254] [INFO] cache worker(pid:4623-1243-1728264672) got handover from peer

[2024-10-09 10:03:05,284] [DEBUG] Error <class 'OpenSSL.SSL.SysCallError'>:(104, 'ECONNRESET')

SysCallError: (104, 'ECONNRESET')

Cause

  • The CloudCache device could not establish a secure connection with Druva Cloud services due to an issue with DNS resolution or Web Proxy configuration.

  • This resulted in failed TLS handshakes and disrupted communication with the Druva Cloud.

Resolution:

To resolve this issue:


1. Verify Web Proxy Configuration

2. Update DNS Records & FQDN

  • Ensure the FQDN (Fully Qualified Domain Name) of the CloudCache device is correctly configured.

  • Update the DNS records if necessary so the device can resolve required endpoints.

3. Restart CloudCache Services

  • After making the above changes, restart the CloudCache services or reboot the appliance.

If you continue to experience issues, please contact Druva Support with the latest logs from:

  • Linux (CloudCache R1): /var/log/PhoenixCloudCache/

  • Linux (CloudCache R3): /var/log/Druva/EnterpriseWorkloads/cloudcache/

Did this answer your question?