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The agent upgrade fails with error code 1618, indicating that another installation is already in progress.
The agent upgrade fails with error code 1618, indicating that another installation is already in progress.

The agent upgrade fails with error code 1618, indicating that another installation is already in progress.

Updated this week

Problem description

The Phoenix client upgrade from the Druva console for Windows server fails with an MSI (Microsoft Installer) installer error: Another installation is in progress.

Cause

The Phoenix client installation on the Windows server fails due to the occurrence of a general MSI install error: Error 1618.

This error occurs due to the following reasons:

  • If there are any MSI-based installers running already. The MSI engine does not allow two installers to run simultaneously.

  • The in-progress key left behind if an earlier installation attempt is canceled forcibly through the Task Manager (Ctrl+Alt+Del) during the transaction or the installation process.

Traceback

Controlservice.log

Install.log

Resolution

  • Stop or remove all MSI installers from the Task Manager.

  • Open Services console(services.msc) and start Agent Client Service.
    Agent Version 6.x.x: Hybrid Workloads Agent Client Service.
    Agent Version 7.x.x: Druva-EnterpriseWorkloads Service

  • Re-try the upgrade from the Druva console UI

Validation

  • After completing the steps, verify the agent is functioning correctly.

  • Confirm the upgrade was successful in the console.

See also

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