Skip to main content
All CollectionsKnowledge BaseEnterprise WorkloadsTroubleshooting - Enterprise Workloads
While Upgrading, Uninstalling, Installing Druva Phoenix Agent on a Windows Server we get error “The feature you are trying to use is on a network resource that is unavailable”
While Upgrading, Uninstalling, Installing Druva Phoenix Agent on a Windows Server we get error “The feature you are trying to use is on a network resource that is unavailable”
Updated over 3 months ago

Problem description

When Upgrading, Uninstalling, Installing Druva Phoenix Agent on a Windows Server you receive the Error below:

The feature you are trying to use is on a network resource that is unavailable.

Click OK to try again, or enter an alternate path to a folder containing the installation package ’Phoenix-6.0.1-154928.msi’ in the box below.

Use source: C:\ProgramData\phoenixupgrade\msi\


📝 Note
The Version number Phoenix-6.0.1-154928.msi in the Error above is an Example. You may receive this Error message with a different Version number.


Cause

  • This Error may occur if you have unrecognizable registry values belonging to the Druva Phoenix agent that you are trying to upgrade, install or or uninstall.

  • The installation/uninstallation package is trying to access a location that is, for some reason, unavailable to the upgrade, installation or uninstallation process.

Resolution

To solve this problem please follow the steps below:

  1. Click the 'Browse' button in the Error box

  2. Navigate to the msi installation file for the Version mentioned in the Error you received. This Version number corresponds to the Version that is currently installed on the Windows Server.

    In case you no longer have the msi file on your Server you can download it from Druva's website. To download the msi file follow the steps below:

    1. Write down the Version number reported in the Error you received.
      For example: Phoenix-6.0.1-154928.msi

    2. Go to the Druva Phoenix Downloads page at https://downloads.druva.com/phoenix

    3. Make sure that in the 'Select Agent' box it shows 'File Server' and Make sure in the 'Select Cloud' box it shows 'Phoenix Cloud'

    4. Under the 'Windows - 64 bit' box right click the 'Download' button and click 'Copy Address link'

    5. Open a Text Editor (Notepad, Notepad ++, or Sublime Text) and paste the address link you copied. The address link should be similar to the link below: https://downloads.druva.com/download...3.0-252659.msi

    6. In the address link you copied from Druva's website and pasted in your test editor, replace the version number from the link by the Version number from the Error you received.
      Example: Link from copied from the Druva Downloads page: https://downloads.druva.com/download...3.0-252659.msi
      New Link to download the msi file needed to Upgrade, install or uninstall : https://downloads.druva.com/download...0.1-154928.msi

    7. Copy and paste your new link in a new web browser window to download the msi file needed

  3. Click the 'Browse' button and navigate to the location where the new msi file has been downloaded.

  4. Select the msi file and proceed with the Upgrade, install or uninstall process.

Did this answer your question?