Problem description:
When we configure the %userprofile% or All Drives location for the Windows Endpoint devices, it does not backup the Desktop directory/folder.
Summary
When OneDrive is installed on the Windows Endpoint devices, it changes the Default location of the “Desktop” folder.
The default location of the Desktop folder gets changed to “C:\Users\<username>\OneDrive - <Org name>\Desktop”.
This is why the “Desktop” location is no longer available under the C:\Users\<username>\ directory.
If we exclude the OneDrive backup of the profile configuration, Druva inSync Client will not backup the Desktop location as the default location does not have the Desktop folder.
This is OneDrive’s expected behavior.
Similarly, other folders default location can be changed if user have made such changes while configuring their OneDrive.
Cause:
OneDrive changes the default location of the selected folders to C:\Users\<username>\OneDrive - <org name> directory.
Resolution:
To resolve this issue, we need to change the Default location of the Desktop folder or any other folder in question.
How to do that :
Go to the User’s Windows Endpoint device and navigate to the location C:\Users\<username>\OneDrive - <org name>\ directory :
Right-click on the Desktop folder and go to Properties–>Location tab
Click on the option “Restore Default”.
This will restore the default location of the Desktop folder to C:\Users\<username>\Desktop directory.
Once done, inSync Client will start backing up the user’s Desktop from the User profile.
Kindly note, please follow and read the pop-ups carefully when you save the changes mentioned in step 4.
Similar steps applicable if any other folder’s default location is changed to OneDrive and they are not backing up with inSync Client.