Skip to main content
VM not visible in Phoenix console due to missing UUID
Updated over 10 months ago

This article applies to:

  • Product edition: Phoenix

Problem description

VM is not visible on the Management Console due to missing UUID.

Cause

Management Console does not list the VM for which the UUID of the disk is missing.

Traceback

[2018-09-06 10:11:22,561] [WARNING] One of the VM's VMDK have none as UUID. Skipping VM: <VM NAME> from listing
[2018-09-06 10:11:22,571] [INFO] list_vm total data size=1382

Resolution


❗ Important

All these steps need to be performed on the vCenter or ESXi. Engage your VM Team to perform all the prescribed steps below.


  1. Confirm whether the UUID of the VM disk is missing.

    Use the steps described in the Backup software shows error: Disk does not have a UUID (1033370) section of the VMware documentation to confirm this.

    Alternatively, run the following command, to get a unique identifier (UUID) for the virtual disk stored in the descriptor file of the virtual disk. Login to the ESX/ESXi host as root to execute the vmkfstools command listed.

    #vmkfstools -J getuuid /vmfs/volumes/datastore/VM/vm.vmdk

    In the above command:

    • datastore is the name of VMFS Volume

    • VM is the name of virtual machine

    • vm.vmdk is the name of virtual disk description file.

  2. If the UUID of of VMDK is confirmed to be missing, fix the missing UUID with the command:

    #vmkfstools -J setuuid /vmfs/volumes/datastore/VM/vm.vmdk


    The above command returns a UUID.

Once each disk of the VM has an associated UUID, the VM gets listed on the Management Console and can be configured for backup.

See also

Did this answer your question?