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Unable to boot a P2V VM after a successful restore
Updated over 10 months ago

Problem description


Unable to boot into a P2V VM after a successful restore. The restore job logs do not show any error. However, users are unable to boot into the VM. The VM has a blank screen with a cursor.

Cause

The issue occurs when we are unable to gather the correct information about VMDK BIOS cylinders, heads, and sectors from the source machine during backups. This information is stored in the BIOS and is required to boot into a restored VM.

Resolution

  1. Login to the ESX server that hosts the source and restored virtual machine via SSH.

  2. Navigate to the following paths to locate the descriptor file of the source and the restored virtual machine:
    โ€‹ Source VM:

     /vmfs/volumes/DataStore/SourceVirtualMachineName/SourceVirtualMachineName.vmdk


    โ€‹ Restored VM: /vmfs/volumes/DataStore/RestoredVirtualMachineName/RestoredVirtualMachineName.vmdk
    The highlight in the image below shows one such descriptor file of a restored P2V VM. The file looks like a regular VMDK file, however is much smaller in size.
    โ€‹

    Sample descriptor file.png
  3. Open the source and the restored virtual machine's descriptor file and look for the information highlighted in the image below.
    โ€‹

    Descriptor file descriptions.png
  4. If the following fields in the source and the restored VM's descriptor files vary, perform the following tasks:

    1. Power off the restored virtual machine.

    2. Copy the information from the source descriptor file and paste it into the restored VM's descriptor file:

      db.geometry.biosCylinders = "xxxxx"
              ddb.geometry.biosHeads = "xxx"
              ddb.geometry.biosSectors = "xx"
    3. Ensure that these values are identical in the source and restore VM's descriptor files.

    4. Power on the restored virtual machine. You should now be able to boot into it.

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