All Collections
Knowledge Base
Enterprise Workloads
Troubleshooting - Enterprise Workloads
VM backups fails with Invalid VCenter/ESXi host credentials
VM backups fails with Invalid VCenter/ESXi host credentials
Updated over a week ago

Problem description

This issue occurs when the Vcenter or ESXI account used for backups is a domain account and the password is not updated in the VMware console identity provider section

Cause

Password changed and not updated on VMware console identity provider section.

Traceback

[2023-05-31 10:57:30,419] [ERROR] SyncError: Invalid VCenter/ESXi host credentials(VCENTER_NAME.domain.com)
[2023-05-31 10:57:30,419] [ERROR] Error <class 'pyVmomi.VmomiSupport.vim.fault.InvalidLogin'>:(vim.fault.InvalidLogin) {
dynamicType = <unset>,
dynamicProperty = (vmodl.DynamicProperty) [],
msg = 'Cannot complete login due to an incorrect user name or password.',

Resolution

  1. Update the password on VMware console under Administration > SSO > Configuration > Identity provider > Identity source.

  2. Update the password on VM proxy using ProxyConf and test the backups.

See also

Did this answer your question?