Problem description
Hyper-V VM backup fails with HYPERV3 error.
Cause
A change in Hyper-V Cluster or SCVMM credentials can cause this error.
Traceback
[2020-04-13 20:02:18,885] [ERROR]
<_MainThread(MainThread)> Error <class
'inSyncLib.inSyncError.SyncError'>:LogonUser:
incorrectError Code : HYPERV3
(most recent call last):
File "agentPartnerProcess.pyc", line 84, in _process_request_start
File "agents\hyperv\hypervAgent.pyc", line 67, in process_backup_start
File "agents\hyperv\hypervBackup.pyc", line 77, in init
File "agents\hyperv\hypervBackup.pyc", line 236, in __validate_mgmt_entity
File "roboHyperVUtils.pyc", line 109, in validate_mgmt_entity
File "hypervCredsMgr.pyc", line 390, in validate
File "hypervCredsMgr.pyc", line 339, in _validate
File "inSyncLib\inSyncError.pyc", line 30, in raise_error
SyncError: LogonUser:The user name or password is incorrect. (#100090003 : 1326) (Error Code : HYPERV3)
Resolution
Use the following command to update the credential of the affected Hyper-V host.
Agent Version 6.x and older agent:
Go to Command Prompt (cmd) and run it with administrative privileges.
In command prompt navigate to
C:\Program Files\Druva\Phoenix Agent\
Run the below mentioned command.
Command:
PhoenixHyperVControl.exe set_credential --type <scvmm/cluster> --scvmm_fqdn <scvmm FQDN> --user <scvmm/cluster username> --password <scvmm/cluster password>
Example:
PhoenixHyperVControl.exe set_credential --type scvmm --scvmm_fqdn=192.0.2.9 --user=exampledomain\user --password=Ex@mpleP@$$w0rd
Agent Version 7.x and newer agent:
Go to Command Prompt (cmd) and run it with administrative privileges.
In command prompt navigate to
C:\Program Files\Druva\EnterpriseWorkloads\
Run the below mentioned command.
Command:
EnterpriseWorkloadsAgent.exe hyperv configure --type <scvmm/cluster/standalone> --scvmm_fqdn <scvmm FQDN> --user <username>
Example:
EnterpriseWorkloadsAgent.exe hyperv configure --type cluster --user Domain\user_name
📝 Note
Do not use the following characters in the command:
Double quotes "
Single quotes '
Double back-slash \\
In case the above resolution steps does not work then follow the below steps to re-register the host and attempt to update the credentials as a workaround.
Agent Version 6.x and older agent:
Stop the Hybrid workloads Agent Client Service.
Rename the directory
C:\ProgramData\Phoenix
toC:\ProgramData\Phoenix.old
Start the Hybrid workloads Agent Client Service.
Follow the steps as mentioned in document to re-register a Hyper-V Host.
Agent Version 7.x and older agent:
Stop the Druva-EnterpriseWorkloads Service.
Rename the directory
C:\ProgramData\Druva
toC:\ProgramData\Druva.old
Start the Hybrid workloads Agent Client Service.
Follow the steps as mentioned in document to re-register a Hyper-V Host.