Skip to main content

TurboTier warning - Server fails to connect to TurboTier to back up or restore

Updated over a week ago

This article applies to:

  • OS: Windows, Linux

  • Product edition: Enterprise Workloads

Problem description

The Enterprise Workloads Management Console displays an error message:

Server is not able to connect to CloudCache for backup / restore.

However, the TurboTier connection status appears green on the console. The TurboTier service also appears running and sometimes, the following message appears in the logs:
​Could not connect to CloudCache server.

Traceback

The TurboTier logs contain:

[Errno 10013] An attempt was made to access a socket in a way forbidden by its access permissions

Cause

This issue occurs when the port 443 used by an application other than TurboTier. There is a conflict of the port as TurboTier also tries to use the same port for communication.

Resolution

  1. Run below command prompt to check the port usage. The command will list the ports in use.
    ​netstat -an

  2. Check if the server has IIS role installed. Stop the IIS service if it is running. This will release the 443 port.

  3. Restart the TurboTier service

    1. For CC R1: Restart the Phoenix TurboTier service
      ​Command is : service PhoenixCacheServer restart

    2. For CC R3/R4: Restart the Druva Cache Server service
      ​Command is : systemctl restart Druva-EnterpriseWorkloads.service
      This will resolve the issue and backups will resume successfully.


πŸ“ Note
​ Install the IIS role and TurboTier on different servers.


Did this answer your question?