Problem description
Hyper-V VM restore fails with error code HYPERV11
Cause
The account “virtual machines” doesn’t have write permissions on the folder where the VM guest state is stored.
Traceback
Follow the instructions provided in the link below to obtain job logs.
How to collect the detailed job logsExtract the logs and go to Phoenix<YYYYMMDD>_<timestamp>.log file to see the below traceback in the logs.
SyncError: Import failed. Import task failed to copy file from 'X:\Druva Backups\Planned \Virtual Machines\Phoenix\xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx.vmgs' to 'C:\ProgramData\Microsoft\Windows\Hyper-V\Planned Virtual M)achines\xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx.vmgs': The file or directory is corrupted and unreadable. (0x80070570). (#10009000b : 32768) (Error Code : HYPERV11
Resolution
The vmgs file is used for version 8.2 or higher Hyper-V virtual machines and is used to store the virtual machine guest state. It is located in the configured Disk folder on the local disk in case of standalone Hyper-v host or on the CSV volume in case of Clustered Hyper-v hosts
e.g. C:\ProgramData\Microsoft\Windows\Hyper-V\Planned Virtual Machines
in the above log snippetThe virtual machine data gets restored to the location specified during the restore however saving the guest state fails which causes the restore to fail
Edit the permissions for the folder and assign the account “virtual machines” write permission.
Rerun the restore and it should be successful