This article applies to:
OS: Mac
Product edition: inSync Client 6.0.1 and 6.1.0
Problem description
The following issues are observed after installing the inSync Client on a Mac device:
inSync Client fails to launch on the Mac device.
inSync icon is not created on the taskbar.
inSync process gets killed shortly after opening from Application.
Cause
inSync Client creates a few entries under Keychain Access by default during its installation. However, in absence of sufficient permissions from Mac OS, inSync fails to create the entries under the Keychain Access.
The Mac OS fails to provide the required permissions if its System Integrity Protection (SIP) component has developed an issue. As a result, inSync fails to get sufficient permissions to write to the system keychain.
Traceback
The solitary log saved to inSyncSyncer.log file at ~/Library/Application Support/inSync is as follows:
The following traceback is saved to inSyncClienGUI.log
[INFO] Error while config activation , The user key is either invalid or the username no longer exists. (#100000016)
Resolution
Perform the steps provided below to resolve this issue:
Stop or disable the System Integrity Protection (SIP):
Log on to the Mac device and uninstall inSync completely without keeping any settings.
Click No when asked to retain inSync settings.
Reinstall the inSync Client and activate it.
Enable SIP as follows:
Stop or disable the System Integrity Protection (SIP):
Shut down the Mac device (Apple > Shut Down).
Keep Command-R pressed and switch on the device. Keep Command-R pressed until the Apple logo appears.
Wait for OS X to boot the OS X Utilities window.
Select Utilities > Terminal.
Run the following commands:
csrutil enable reboot