All Collections
Knowledge Base
inSync Client
Troubleshooting - inSync Client
inSync Client displays rpc method not supported error on backup
inSync Client displays rpc method not supported error on backup
Updated over a week ago

This article applies to:

  • OS: Windows

  • Product edition: inSync On-Premises and Cloud

Problem description

inSync Client displays the rpc method not supported error on backup.

rpcError.png

Cause

If the version of inSync Client installed on the device is higher than the version of inSync Server, inSync does not support backup from such a device. For example, if inSync Client version 5.8.6 is installed on the device and if the inSync Server version is 5.8.4, the backup fails. inSync Client displays the rpc method not supported error in this case.

Although this scenario is applicable to both inSync Cloud and On-Premises, its occurrence in the cloud environment is likely to be remote, as inSync Server always runs its latest version on the Cloud.

To check inSync Client version:

  1. Open Control Panel > Programs and Features.

  2. Check the version of Druva inSync in the list of programs.

inSync Client version is also displayed on the My Account tab of the client.

MyAcTab.png

Resolution

  1. Uninstall inSync Client from the device.

  2. On the Task Manager, verify whether all the inSync processes are closed. Kill inSync processes if required.

  3. The following processes must close:

    • inSync.exe

    • inSyncAgent.exe

    • inSyncCPHwnet64.exe

    • inSyncUSyncer.exe

  4. Delete the inSync4 folder from C:\ProgramData\Druva\inSync4 (For inSync 5.8 and above) and C:\inSync4 (For inSync 5.5 client version)

  5. Install the supported version of inSync Client. Backups will succeed provided the inSync Server versions is greater or equal to that of inSync Client.

Did this answer your question?