Problem description
If the profile has Email option selected to backup as ‘Optimized with efficiency’. Backup fails at outlooks Sync stage. Email using Optimized for Performance gets backed up successfully.
Cause
inSyncUSyncer process is crashing as it starts backing up outlook.
Perform below steps to confirm :
Stop Druva inSync Client Service.
Start Druva inSync Client Service.
Monitor processes in the task manager.
Start the backup
After flat file data is backed up as it starts synchronizing outlook inSyncUSyncer will exit.
Traceback
+snip+ [2021-12-15 12:35:47,157] [INFO] Synchronizing Outlook Advanced [2021-12-15 12:36:02,529] [ERROR] Error <class 'socket.error'>:[Errno 10054] An existing connection was forcibly closed by the remote host. Traceback -Traceback (most recent call last): File "inSyncLib\inSyncRPCBase.pyc", line 505, in __recv error: [Errno 10054] An existing connection was forcibly closed by the remote host
[2021-12-15 12:36:02,532] [WARNING] Outlook Sync failed: can't connect to USyncer.Network not reachable. (#100000022) +snip+
+snip+ Log Name: Application Source: Application Error Date: 12/15/2021 2:42:14 PM Event ID: 1000 Task Category: (100) Level: Error Keywords: Classic User: N/A Computer: XXXXX Description: Faulting application name: inSyncUSyncer.exe, version: 0.0.0.0, time stamp: 0x5f046ea7 Faulting module name: KERNELBASE.dll, version: 10.0.19041.1387, time stamp: 0x0b9a844a Exception code: 0x80040813 Fault offset: 0x000000000010b302 Faulting process id: 0x1de8 Faulting application start time: 0x01d7f19329cc2b40 Faulting application path: C:\Program Files (x86)\Druva\inSync\amd64\inSyncUSyncer.exe Faulting module path: C:\Windows\System32\KERNELBASE.dll Report Id: 8c2bb8ec-3fb7-453a-a9fa-f7bdf8d3ff66 Faulting package full name: Faulting package-relative application ID:
Log Name: Application Source: Outlook Date: 12/15/2021 2:42:14 PM Event ID: 2000 Task Category: None Level: Error Keywords: Classic User: N/A Computer: XXXXXX Description: Database corruption was detected and the process was terminated. Process: "<unknown_process>" (1de8.3b4) Version: 16.0.10380.20037 File: "D:\Mail\My Outlook Data File.pst" Last: "C:\Program Files (x86)\Druva\inSync\amd64\inSyncUSyncer.exe" Database Version: 23 (2) Context: 10037001 Details: BCRead(@38CD629C0): Expected (bid=62BF920,cb=8176,dwCRC=A26A3244,wSig=5A1D), but read (bid=62BF920,cb=8176,dwCRC=4693ABAC,wSig=5A1D) +snip+
Repairing the PST file does not help.
Resolution
Try repairing the PST file and then run the backup. If it still fails, Export all emails to a new PST file. Remove old problematic PST and attach new exported PST.
Verification
Backup should be successful for the new exported PST file.
Monitor task manager for inSyncUSyncer process, it does not crash.