This article applies to:
OS: Not applicable.
Product edition: inSync Cloud
Problem description
SharePoint backup fails with the following message in the activity log:
📝 Note
“[ERROR] SharePoint Backup failed for sitecollection 11334, reason: {u'odata.error': {u'message':
{u'lang': u'en-US', u'value': u'Access to this Web site has been blocked.\n\nPlease contact the
administrator to resolve this problem.'}, u'code': u'-2130575247, Microsoft.SharePoint.SPException'}}
(#100000001)”
From Microsoft 365, the activity log can be accessed from Data Sources > Microsoft 365 > SharePoint > Site > Activity Stream.
Cause
SharePoint site is blocked in Microsoft 365.
inSync does not back up locked SharePoint sites.
Resolution
The resolution requires unlocking the SharePoint sites.
❗ Important
Inform the SharePoint administrators before unlocking the SharePoint sites.
Use Powershell to unlock the SharePoint site. (There is a separate PowerShell module for SharePoint Online.)
Download the SharePoint Online Management shell form its download link.
Launch the SharePoint Online Management shell and run the following command:
“connect-sposervice -url https://<domain>-admin.sharepoint.com”
When prompted, enter the global admin credentials for Microsoft 365.
Check whether the following site status command returns the lock state as 'NoAccess'.
“get-sposite -identity https://<domain>.sharepoint.com/sites/<sitename>”
Unlock the site as follows:
“Set-sposite -identity https://<domain>;.sharepoint.com/sites/<sitename> -lockstate unlock”
Post unlock, initiate a backup of the site.