This article applies to:
OS: Windows and Linux
Product edition: inSync On-Premises
Problem description
inSync fails to send notification emails from the On-Premises server and displays the following error. The error also appears in response to a test email.
Cause
Emails from inSync fail with the above error if the SMTP password configured on the inSync server contains non-Ascii characters.
Traceback
The following traceback is generated at C:\ProgramData\Druva\inSyncCloud\logs\CPortal.log
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[2017-11-28 1110:05,589] [ERROR] Error <class 'inSyncLib.inSyncError.SyncError'>:SMTP server rejected sender. (#100000010). Traceback -Traceback (most recent call last):
File "inSyncWWWLib\Email.pyc", line 117, in send_test_email
File "inSyncLib\inSyncSMTP.pyc", line 118, in send_email
File "inSyncLib\inSyncSMTP.pyc", line 216, in send_email_lock
SyncError: SMTP server rejected sender. (#100000010)
[2017-11-28 11:10:05,589] [INFO] Request Duration 10281 ms, Req count [2] : (POST /admin/email/send_test_email HTTP/1.1) [User: xyz@abc.com, cid:0]
[2017-11-28 11:10:20,831] [ERROR] Error <type 'exceptions.UnicodeEncodeError'>:'ascii' codec can't encode character u'\u20ac' in position 2: ordinal not in range(128). Traceback -Traceback (most recent call last):
File "inSyncWWWLib\Email.pyc", line 102, in send_test_email
UnicodeEncodeError: 'ascii' codec can't encode character u'\u20ac' in position 2: ordinal not in range(128)
Resolution
Reset the SMTP account password with valid Ascii characters.
See also
See Configure an email account for inSync Master section for more information.