This article applies to:
OS: Windows
Product edition: inSync Cloud and On-Premise
Problem description
When attempting to use the Mass Deployment for endpoints, a failure occurs when the deployments do not proceed as expected. The uploaded CSV contains the correct values for email ID, hostname, device ID, device ID type, and username. The issue is particularly observed when the hostname is used as the identifier during the activation process which is more than 15 characters.
Cause
During the inSync Client activation, Windows OS returns a 15-character string due to the naming conventions used for computers, domains, sites, and OUs in the Active Directory.
You can find the traceback in inSyncClientGUI.log which is located in the
Windows : C:\programdata\druva\inSync4\users\<user>
Mac OS : /Users/support<username>/Library/Application Support/inSync
[2024-08-09 02:47:49,664] [INFO] IMDv4 - Hardware Identifier(s) :
{'serial-number': u'VMware-56 4d 78 c9 92 c8 24 bd-36 df ee a6 4f 98 c1
fb', 'uuid': u'C9784D56-C892-BD24-36DF-EEA64F98C1FB', 'hostname':
u'testmachine.testdomain.com’
Resolution
You need to use the NetBios names in the input CSV file uploaded to the cloud. This allows the computer name to match during the activation.
Run any one of the following commands from the Windows command prompt to get the Netbios name of the device:
hostname
nbtstat -n
See also