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IMD activation fails for the user in a Non AD/LDAP environment
IMD activation fails for the user in a Non AD/LDAP environment
Updated over a week ago

Problem description

Activating the user in a Non AD/LDAP environment fails. The command completes without any error on the command prompt. Manual activation works fine.

Cause

The username logged in on the Druva inSync Client machine does not match with the user name mentioned in the ‘Device Mapping’ file.

Traceback


📝 Note
[2019-05-07 0719:51,397] [DEBUG] Could not fetch IMDv3 token. Error : EOF read where object expected[2019-05-07 07:19:52,033] [INFO] IMDv3 - User Name : XXXX[2019-05-07 07:19:52,062] [INFO] IMD Details: email:None, massDeploy_ver: 3, objectSID_found: False[2019-05-07 07:19:52,069] [DEBUG] isocket shutdown failed, [Errno 57] Socket is not connected.[2019-05-07 07:19:54,022] [DEBUG] Found error while reading tokenv4 from keychain - error EOF read where object expected


Resolution

Make sure the device mapping file has the exact same username as logged in on to the machine.

Confirm other details are correct.

Verification

Once the device mapping details are corrected the IMD command should complete and user should be activated on the machine.

See also

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