This article applies to:
Product edition: inSync Cloud
Problem description
While trying to download data using inSync Direct Download utility, the download fails with the error401 Invalid Credentials .
Cause
The error is displayed in case of :
The credentials of the administrator account used in the following command are incorrect.
inSyncDirectDownload.exe -u <admin email id> -p <admin password> -l <location for downloading the data> -c <location of the csv file>
The administrator does not have enough privileges to download legal hold users data.
The token copied from ‘Access token for inSync APIs’ may have expired or is incorrect.
Traceback
{snippet}
2018-09-24 13:15:35,295 [ERROR] - 401 Invalid credentials for webdav access while downloading metadata for user: abc.xyz@druva.com, device: TestDevice, and webdav url: https://testurl.com/webdav/2016-002614/GARG/
{snippet}
Resolution
Ensure that the admin credentials used in the following command are correct.
inSyncDirectDownload.exe -u <admin email id> -p <admin password> -l <location for downloading the data> -c <location of the csv file>
Perform the data download using a Cloud Administrator or Legal Hold administrator account.
Use the correct inSync token in the following command:
inSyncDirectDownload.exe -u <admin email id> -p <Token> -l <location for downloading the data> -c <location of the csv file>