Skip to main content
All CollectionsKnowledge BaseAWS WorkloadsTroubleshooting - AWS Workloads
FLS Index Job fails in CloudRanger with the Error: "The instance configuration for this AWS Marketplace product is not supported. Please see the AWS Marketplace site for more information about supported instance types, region, and operating systems."
FLS Index Job fails in CloudRanger with the Error: "The instance configuration for this AWS Marketplace product is not supported. Please see the AWS Marketplace site for more information about supported instance types, region, and operating systems."
Updated over 11 months ago

Problem description

  • Backups may fail with the Error above when you have enabled the feature 'Index all Backups' in your Account Settings in CloudRanger.

  • You can see the location where to enable or disable the feature ‘Index all Backups’ on the picture below:

  • When the feature 'Index all Backups' is enabled in your Account Settings in CloudRanger, an additional step is performed towards the end of each Backup that runs in CloudRanger.

  • This additional Step consists of indexing all Backups located on Amazon S3 after they are created.

  • Enabling the feature 'Index all Backups' allows you to perform File-Level Search (FLS) to search file systems within snapshots on your Backups sitting in Amazon S3.

  • This allows you to search files to confirm whether files exist in the Backup or if they have been deleted.

  • Note that the File Level Search feature is optional and does not impact your ability to perform a File-Level Restore in CloudRanger if needed.

  • For more information on the feature 'Index all Backups' please take a look at the article below: https://docs.druva.com/CloudRanger/F...ch_for_Backups

Cause

The reason why the FLS Indexing Job fails is because the Instance you are trying to backup is a marketplace Instance. Druva CloudRanger does not support FLS indexing for marketplace instances.

Traceback

<Include the traceback content here>

Resolution

  • To resolve this problem and allow your Backups to run successfully you need to disable the feature 'Index all Backups' in CloudRanger by unchecking the box 'Index all Backups' in your Account Settings.

  • Note that Indexing is a global feature and it gets enabled or disabled for all Backups.

  • After disabling Indexing CloudRanger will stop trying to index all your Backups.

  • If you have other Instances that are not marketplace instances and that you want to perform File Level Search on, you can perform File Level Search on their Backups manually at anytime if needed as shown on the article below: https://docs.druva.com/CloudRanger/F...ch_for_Backups

See also

Did this answer your question?