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Restore job failed due to SQL server compatibility level mismatch
Restore job failed due to SQL server compatibility level mismatch

Restore job failed due to SQL server compatibility level mismatch

Updated over a month ago

Problem Description

The restore job failed with error code SQL12 due to a compatibility issue between the source SQL Server 2012 (version 11.0.7507) and the target SQL Server 2019 (version 15.0.4365.2), likely caused by mismatched compatibility levels.

Traceback

[2024-09-22 07:39:23,805] [INFO] <_MainThread(MainThread)> roboSyncer: Sending log to Phoenix server with message : 'Databases [[u'DatabaseServer\\ABC', u'DatabaseServer\\ABC', u'DatabaseServer\\ABC', u'DatabaseServer\\ABC', u'DatabaseServer\\ABC', u'DatabaseServer\\ABC', u'DatabaseServer\\ABC']] not supported on target [15.0.4365.2]'

Cause

  1. Restore job failed due to compatibility level set to 90 on affected databases.

    1. SQL Server 2019 (version 15.0.4365.2) does not support compatibility level 90, requiring a higher level.

    2. SQL Server 2012 (version 11.0.7507) supports compatibility level 90, but it is outdated for the target environment.

  2. Druva does not support databases configured with SQL Server 2005 compatibility levels (level 90).

  3. Compatibility for each database can be verified in the SQL discovery file (c:\ProgramData\Druva\EnterpriseWorkloads\logs\mssql\sqldiscovery.json).

  4. For reference, here is the current compatibility configuration fetched from SQL discovery:

    1. 'Database1': { 'compatibility_level': 90 }

    2. 'Database2': { 'compatibility_level': 90 }

    3. 'Database3': { 'compatibility_level': 90 }

Solution/Workaround

To resolve the compatibility issue, consider the following options:

  1. Adjust Compatibility Level on the Source Server:

    • Change each database’s compatibility level on the source server from 90 to at least 100.

    • Perform a full backup of the database after adjusting the compatibility level, as this may require a fresh full backup.

    • Once the full backup is complete, try restoring to the target server.

  2. Restore to an Alternate Server:

    • Restore the backup to an alternative server running SQL Server 2012 (version 11.0.7507), which supports compatibility level 90.

  3. Install SQL Server 2012 on Target Server:

    • If using the Druva backup on the source database is not a requirement, install SQL Server 2012 (version 11.0.7507) on the target server to accommodate the compatibility level 90 databases.

Additional Information

  1. Druva’s backup and restore processes verify compatibility levels between source and target databases.

  2. These checks ensure alignment with Microsoft’s SQL Server compatibility requirements.

  3. Bypassing Druva’s compatibility checks would still require the target server to meet Microsoft’s compatibility support levels for a successful database restore.

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