Skip to main content
All CollectionsMicrosoft 365FAQs SaaS Apps
Saas Apps | Exchange Online backup continues even after the user is deleted in M365
Saas Apps | Exchange Online backup continues even after the user is deleted in M365
Updated over 3 months ago

Problem description

Exchange Online Backup continues to run successfully even after deleting the mailbox from Exchange Online in M365.

Cause:

Exchange Online mailbox is not deleted if the user is in a soft deleted state. The user will be in a soft deleted state for 30 days. Due to this behavior, the Graph API will return the data to Druva as the user's account will be present on the Exchange Online server.

Resolution:

  1. After 30 days, the user's account is permanently deleted. So, the Exchange Online mailbox also gets deleted. Now the Graph API won’t return any data to Druva and the backup will fail with error EUSERNOTFOUND.

  2. We need to wait for 30 days until the user is deleted from the Exchange Online mailbox server.

Did this answer your question?