Problem description
This issue can be faced if Backup Proxy pool is used for backup proxies.
Backup jobs will run as per the TimeZone set for backup proxy pool.
Cause
Timezone of the Backup proxy pool is different.
Resolution
Login to Druva Console
Navigate to Hybrid workload Agent.
Select your organization
Select VMWare from the ProtectMenu.
Select your vCenter/ESXi Host
Go to the Backup proxy page.
Select to Backup Proxy pool Tab
Click on the Backup Proxy Pool
Click on Edit on the Backup Proxy pool Details page.
Change the Time Zone and click on Save.