Skip to main content
All CollectionsKnowledge BaseEnterprise WorkloadsTroubleshooting - Enterprise Workloads
Discovery of RAC database for Oracle DTC workload is not working
Discovery of RAC database for Oracle DTC workload is not working
Updated over 10 months ago

Problem description

After the RAC servers were registered, no databases were found or displayed in the console.

Cause

OS language was configured to Spanish. The Oracle DTC agent supports only English.

Traceback

nMáximo de Memoria: 0\nNúmero de red por defecto para los servicios de base de datos: \nLa base de datos está gestionada por el administrador\n"
level=error ts=2023-03-30T12:46:44.599981629+02:00 filename=instance.go:346 message="Failed to Get Rac Details" Layer=OracleApi Message="Removing this instance from discovery" Error="DB Info not found"

Resolution

  1. First use this command to check the system language:
    # localectl

  2. If Spanish(es_ES.UTF-8) or any other language is detected, then change the language to English(en_US.UTF-8) on both RAC nodes using the command:
    # localectl set-locale LANG=en_US.UTF-8

  3. Restart Phoenix Oracle service on both nodes using this command:
    systemctl restart PhoenixOracle

  4. Go to Druva console, trigger Discover database

    Picture23.jpg
Did this answer your question?