Skip to main content
All CollectionsKnowledge BaseEnterprise WorkloadsTroubleshooting - Enterprise Workloads
VMware file-level restore fails with the error - Failed to browse the guest VM
VMware file-level restore fails with the error - Failed to browse the guest VM
Updated over 10 months ago

Problem description

You may run into this error while performing a VMware file-level restore (FLR) as you navigate to Configured VMs > select a VM > Restore > VM Restore > Data Restore > Files & Folders > Select the volume > Restore > Restore to Virtual Machine > Restore to original VM. Under the Restore to original VM section, you enter the guest OS credentials and then click Browse. The browse could fail with two errors.

Error 1:

The browse fails with the error Failed to browse the guest VM. Error: Cannot proceed with restore operations. VMware Tools not present in the selected VM.

browse error.png

Cause

You may run into this issue if VMware Tools are not installed on the VM where you want to restore the files or are not functioning correctly.

Error 2:

Failed to browse the guest vm. Error : Invalid Credentials. Please provide correct username and password for the specified VM.

Logs

[2019-12-17 04:44:27,012] [ERROR] Error in command_guest_vm_browse Invalid Credentials. Please provide correct username and password for the specified VM. (#10007000e : vim.fault.GuestComponentsOutOfDate) (Error Code : FLR14)

Cause:This error may occur if VMware Tools are not up to date.

Resolution

Install VMware Tools on the VM if they are not installed. Reinstall/repair/upgrade VMware tools if they exist and retry the restore.

See also

Did this answer your question?