This article applies to:
Product edition: Phoenix
Problem description
A virtual machine (VM) is not appearing in the Management Console. This usually occurs when one or more of the VM’s virtual disks (VMDKs) are missing a UUID (Universal Unique Identifier).
Cause
The Management Console cannot display a VM if any of its VMDK files are missing a UUID.
Traceback
[2018-09-06 10:11:22,561] [WARNING] One of the VM's VMDK have none as UUID. Skipping VM: <VM NAME> from listing
[2018-09-06 10:11:22,571] [INFO] list_vm total data size=1382
Resolution
⚠️ Important:
All the steps below must be performed directly on vCenter or ESXi hosts. Please involve your VM team or system administrators to carry out these actions.
Step 1: Verify if UUID is Missing
You can check if the UUID is missing using one of the following methods:
Option A: Refer to VMware Documentation
Option B: Use vmkfstools Command
Log in to the ESXi host as root.
Run the following command to check for the UUID of the virtual disk:
vmkfstools -J getuuid /vmfs/volumes/<datastore>/<VM_name>/<vm>.vmdk
<datastore> = Name of the datastore (VMFS volume)
<VM_name> = Name of the virtual machine
<vm>.vmdk = Name of the virtual disk descriptor file
Step 2: Assign a UUID (If Missing)
If the UUID is missing, assign one using the command below:
vmkfstools -J setuuid /vmfs/volumes/<datastore>/<VM_name>/<vm>.vmdk
This command will generate and assign a new UUID for the disk.
Post Resolution
Once all virtual disks of the VM have valid UUIDs, the VM will appear in the Management Console and can be configured for backups.