Problem description
SQL Database Backup fails to create a snapshot. The following entries are logged in the Phoenix Agent logs:
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[ERROR] Backup failed for shareFileName_old.mds with error:Vss Error: GetSnapshotProperties hr = 0x80010108L
[ERROR] Backup failed for share:FileName_old.ndf with error:Vss Error: GetSnapshotProperties hr = 0x800706baL
[ERROR] Error while backing up share FileName. Error: Vss Error: GetSnapshotProperties hr = 0x800706baL
ERROR] SqlAgent :SQL backup failed: Vss Error: GetSnapshotProperties hr = 0x800706baL
[ERROR] Error <class 'pyvss.VssException'>:Vss Error: GetSnapshotProperties hr = 0x800706baL. Traceback -Traceback (most recent call last):
You will also notice some events related to this conflict.
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βLog Name Application
Source: VSS
Date: 2/24/2017 10:23:45 PM
Event ID: 12291
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: <ServerName>
Description:
Volume Shadow Copy Service error: Error on creating/using the COM+ Writers publisher interface: BackupShutdown [0x80042302, A Volume Shadow Copy Service component encountered an unexpected error.
Check the Application event log for more information.
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Log Name Application
Source: BeVssProvider
Date: 2/24/2017 10:23:48 PM
Event ID: 0
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: <ServerName>
Description:
Service started/resumed
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βLog Name Application
Source: VSS
Date: 2/24/2017 10:23:49 PM
Event ID: 8193
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: <ServerName>
Description:
Volume Shadow Copy Service error: Unexpected error calling routine IVssAsync::QueryStatus. hr = 0x800706ba, The RPC server is unavailable.
You may also see
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βLog Name System
Source: volsnap
Date: 10/18/2018 3:06:34 PM
Event ID: 35Task Category: None
Level: Error
Description: The shadow copies of volume X: were aborted because the shadow copy storage failed to grow.
Cause
When the Phoenix agent tries to take a snapshot with the help of Windows Volume Shadow Copy, it fails with the VSS error. This occurs when there is an additional third-party VSS provider installed on the server that creates a conflict when VSS takes a snapshot of the database.
Resolution
Druva recommends to uninstall the third-party VSS provider completely from the server and restart the server when the server utilization is minimal. This will help VSS to gain appropriate access to SQL writer and create a clean snapshot.
If space for VSS Shadow Copy is the suspected issue, perform the following tasks:
β
Enable Shadow copy
Refer : Vssadmin commands
βExample : vssadmin create shadow /for=G:\
Increase the size of the shadow copy storage on the drive.
βExample : vssadmin resize shadowstorage /for=G: /On=G: /MaxSize=UNBOUNDED
If the backup still fails then, Druva recommends uninstalling the third-party VSS provider completely from the server and restart the server when the server utilization is minimal. This will help VSS to gain appropriate access to SQL writer and create a clean snapshot.