Skip to main content
All CollectionsKnowledge BaseEnterprise WorkloadsTroubleshooting - Enterprise Workloads
Share backups on Linux NAS proxy fail with error PHOENIX265
Share backups on Linux NAS proxy fail with error PHOENIX265
Updated over a month ago

Problem description

Share backups on Linux NAS proxy fail with error PHOENIX265

Cause

The user account that mounts the shares on the NAS proxy server does not have read-write permissions.

Traceback

Mounting NAS Share" FQDN=<> Share=/volume1/Phoenix

level=info ts=2020-02-11T19:20:28.210509876-08:00 filename=backup_agent.go:459 message="Mounting NAS Share" FQDN=<> Share=/volume1/Phoenix

level=error ts=2020-02-11T19:20:28.212562195-08:00 filename=mount_unix.go:100 message="Unable to Unmount network path." path=/mnt/NAS/mountpoint/10_volume1_Phoenix -Main_806

level=error ts=2020-02-11T19:20:28.219293994-08:00 filename=mount_unix.go:80 message="Unable to mount network path." path=/mnt/NAS/mountpoint/10_volume1_Phoenix -Main_806 message="m

Errored - mount.nfs:access denied by server while mounting <>:/ Phoenix

Resolution

Give read-write permissions to the user over the NAS share or, execute the following commands to unmount and mount the share on the NAS proxy server.

  1. Shares are mounted under /var/Phoenix/NAS/mountpoint/
    Example /var/Phoenix/NAS/mountpoint/<mount name>

  2. Unmount the share
    # umount /var/Phoenix/NAS/mountpoint/<mount name>

  3. If the issue persists, mount the share on a different folder.

  4. Mount the share on a different folder
    # mkdir /var/Phoenix/NAS/mountpoint/<mount name># mount -t nfs <IP Address>:/volume1/phoenix /var/Phoenix/NAS/mountpoint/<mount name>

If you are using a NetApp NAS device, perform the following additional steps:

  • Exporting file systems to NFS clients - https://library.netapp.com/ecmdocs/ECMP1155590/html/GUID-6A65DB66-6692-4035-B6F9-D909983B5CB1.html

See also

Did this answer your question?