Skip to main content
All CollectionsKnowledge BaseEnterprise WorkloadsTroubleshooting - Enterprise Workloads
Nutanix Full VM Restore and VM disk Restore fail with the Error: AHV 200
Nutanix Full VM Restore and VM disk Restore fail with the Error: AHV 200
Updated over 10 months ago

Problem description

When doing a Full VM Restore or a VM disk Restore in Nutanix AHV, Druva Phoenix fails with the Error: AHV 200

Cause

Invalid Credentials.
The credentials used in Druva Phoenix to access the Prism Central do not have access to Nutanix resources.

Traceback

1 - Full VM Restore:
Phoenix Logs:
message="Abort set" method=Abort error="Failed to prepare for restore job" msg="HTTP Get failed with status: 500,
response: <!doctype html><html lang=\"en\"><head><title>HTTP Status 500 – Internal Server Error</title><style type=\"text/css\">body {font-family:
<body><h1>HTTP Status 500 – Internal Server Error</h1><hr class=\"line\" /><p><b>Type</b> Exception Report</p><p><b>Message</b> HTTP 401 Unauthorized</p><p><b>Description</b> The server encountered an unexpected condition that prevented it from fulfilling the request.</p><p><b>Exception</b></p><pre>javax.ws.rs.NotAuthorizedException: HTTP 401 Unauthorized\n\tcom.nutanix.prism.auth.commands.LDAPAuthenticationProvider.assignUserRoles(LDAPAuthenticationProvider.java:325)\n\tcom.nutanix.prism.auth.commands.LDAPAuthenticationProvider.authenticate

2 - Disk Restore:
Phoenix Logs:
filename=restore_manager.go:20 message="Failed to get cluster" clUUID=1255cbg5-7866-056e-47a2-3cecef567269
stack="HTTP Get failed with status: 500, response: <!doctype html><html lang=\"en\"><head><title>HTTP Status 500 – Internal Server Error</title><style type=\"text/css\">body
{height:1px;background-color:#525D76;border:none;}</style></head><body><h1>HTTP Status 500 – Internal Server Error</h1><hr class=\"line\" /><p><b>Type</b> Exception

Resolution

Update the Nutanix Proxy Credentials on your Prism Central in Druva and use an account that has access to both the Prism Central and the Prism Element for the Restore in Nutanix AHV.

Steps to Update the Backup Proxy Credentials on Prism Central:

  1. Log in to the Phoenix Management Console.

  2. Select your organization if organizations are enabled.

  3. On the menu bar, click Protect > Nutanix AHV.

  4. On the Prism page, select the Prism Element or Prism Central whose credentials you want to update, and then click Update Credentials

  5. In the Update Credentials dialog box enter the updated username and password.

Did this answer your question?