Problem description
VMware backup fails with the following error:
Internal 65535 ().
Not able to login to vCenter Server using the vSphere Web Client.
Cause
This error may occur due to one of the following reasons:
The vCenter server is down because of maintenance.
The reverse proxy service on vCenter server is down.
The vSphere web client service is down.
Misconfigured firewall settings.
Certificate expired.
Traceback
PHOENIX
/var/log/Phoenix/VMWARE/<backupsetID>
[2020-05-10 23:27:00,870] [INFO] vSphereCredManager: [username] : []
[2020-05-10 23:27:00,871] [INFO] vSphereCredManager: [is_vmc] : [False]
[2020-05-10 23:27:00,871] [INFO] vSphereCredManager: [old_fqdn] : [esx-master2.Druva.com]
[2020-05-10 23:27:00,871] [INFO] vSphereCredManager: [new_fqdn] : [esx-master2.Druva.com]
[2020-05-10 23:27:00,871] [INFO] vSphereCredManager: [port] : [443]
[2020-05-10 23:27:00,871] [INFO] Credential found for fqdn [esx-master2.Druva.com] are : username =
[2020-05-10 23:27:00,883] [INFO] Error in opening connection
[2020-05-10 23:27:00,883] [ERROR] Failed to get backup proxy details.
[2020-05-10 23:27:00,884] [ERROR] Error <class 'pyVmomi.VmomiSupport.vim.fault.HostConnectFault'>:(vim.fault.HostConnectFault) {
dynamicType = <unset>,
dynamicProperty = (vmodl.DynamicProperty) [],
msg = '503 Service Unavailable (Failed to connect to endpoint: [N7Vmacore4Http16LocalServiceSpecE:0x000055606b4e8620]_serverNamespace = /sdk action = Allow _port = 8085)',
faultCause = <unset>,
VPXD.log
location /var/log/vmware/vpx/vpxd.log
<YYYY-DD-MM>< TIME> [03992 error 'HttpConnectionPool-000001'] [ConnectComplete] Connect failed to <cs p:0000000008165ed0, TCP:vc.Druva:7444>; cnx: (null), error: class Vmacore::Ssl::SSLVerifyException(SSL Exception: Verification parameters:
--> PeerThumbprint: 39:D4:04:4A:FB:AC:8E:05:EC:45:22:81:3F:45:28:44:4C:C7:25:DF
--> ExpectedThumbprint:
--> ExpectedPeerName: vc.domain.com
--> The remote host certificate has these problems:
-->
--> * certificate has expired)
Resolution
If the vCenter server is down because of maintenance:
Turn ON the vCenter server or create another server with the same name in case of hardware errors.If the reverse proxy service on the vCenter server is down:
Restart this service. See, Configure the Reverse Proxy to Request Client Certificates (VMware documentation).
This service is used to request client certificates.We may encounter this issue if the certificates are not validated.If the vSphere web client service is down.
See, Stopping, Starting or Restarting VMware vCenter Server Appliance 6.x & above services (VMware documentation).If the firewall settings are misconfigured:
Correct the setting for vCenter in the firewall. See, System requirements to backup virtual machines for port and communication protocols for Druva Phoenix and VMware.If the SSL Certificates are expired in VMware vCenter Server Appliance:
See, Renew or Refresh ESXi Certificates (VMware documentation).